diff --git a/ffho/ffho-ap-timer/Makefile b/ffho/ffho-ap-timer/Makefile
index dc1c37b91a2d79ba66f530843b67c246f2e51195..6e2507d4a175066f382199bfc0ed3feb318a31ea 100644
--- a/ffho/ffho-ap-timer/Makefile
+++ b/ffho/ffho-ap-timer/Makefile
@@ -6,7 +6,7 @@ PKG_RELEASE:=$(GLUON_VERSION).$(GLUON_SITE_CODE)-$(GLUON_RELEASE).$(GLUON_CONFIG
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
-include $(INCLUDE_DIR)/package.mk
+include $(GLUONDIR)/include/package.mk
 
 define Package/ffho-ap-timer
   SECTION:=ffho
@@ -29,10 +29,12 @@ define Build/Configure
 endef
 
 define Build/Compile
+	$(call GluonSrcDiet,./luasrc,$(PKG_BUILD_DIR)/luadest/)
 endef
 
 define Package/ffho-ap-timer/install
-  $(CP) ./files/* $(1)/
+	$(CP) ./files/* $(1)/
+	$(CP) $(PKG_BUILD_DIR)/luadest/* $(1)/
 endef
 
 $(eval $(call BuildPackage,ffho-ap-timer))
diff --git a/ffho/ffho-ap-timer/files/usr/sbin/ap-timer b/ffho/ffho-ap-timer/luasrc/usr/sbin/ap-timer
similarity index 93%
rename from ffho/ffho-ap-timer/files/usr/sbin/ap-timer
rename to ffho/ffho-ap-timer/luasrc/usr/sbin/ap-timer
index 1626e9897b13f3114af1acbc05538a3060075b98..cfd4ffb97c746225b594e156a5447a4008115f1a 100755
--- a/ffho/ffho-ap-timer/files/usr/sbin/ap-timer
+++ b/ffho/ffho-ap-timer/luasrc/usr/sbin/ap-timer
@@ -2,7 +2,7 @@
 local timestamp = os.time()
 local uci = require('luci.model.uci').cursor()
 
-function compare(list, value)
+local function compare(list, value)
   if not list then
     return nil
   end
@@ -16,7 +16,7 @@ function compare(list, value)
   return false
 end
 
-function getDay()
+local function getDay()
   local type = uci:get('ap-timer','settings','type')
   if type == 'day' then return 'all'
   elseif type == 'week' then return os.date('%a', timestamp)
@@ -25,7 +25,7 @@ function getDay()
   end
 end
 
-function apSet(value)
+local function apSet(value)
   local execWifi = false
   local radios = {'client_radio0', 'client_radio1'}
   for _, radio in ipairs(radios) do
diff --git a/ffho/ffho-ath9k-blackout-workaround/Makefile b/ffho/ffho-ath9k-blackout-workaround/Makefile
index 762739ca09127d108411d0197c341918680fd72e..9bd831b42be8a79340f422e1abd0993a45db6fd1 100644
--- a/ffho/ffho-ath9k-blackout-workaround/Makefile
+++ b/ffho/ffho-ath9k-blackout-workaround/Makefile
@@ -6,7 +6,7 @@ PKG_RELEASE:=$(GLUON_VERSION).$(GLUON_SITE_CODE)-$(GLUON_RELEASE).$(GLUON_CONFIG
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
-include $(INCLUDE_DIR)/package.mk
+include $(GLUONDIR)/include/package.mk
 
 define Package/ffho-ath9k-blackout-workaround
   SECTION:=ffho
@@ -29,10 +29,12 @@ define Build/Configure
 endef
 
 define Build/Compile
+	$(call GluonSrcDiet,./luasrc,$(PKG_BUILD_DIR)/luadest/)
 endef
 
 define Package/ffho-ath9k-blackout-workaround/install
 	$(CP) ./files/* $(1)/
+	$(CP) $(PKG_BUILD_DIR)/luadest/* $(1)/
 endef
 
 define Package/ffho-ath9k-blackout-workaround/postinst
diff --git a/ffho/ffho-ath9k-blackout-workaround/files/lib/gluon/upgrade/900-ath9k-blackout-workaround b/ffho/ffho-ath9k-blackout-workaround/luasrc/lib/gluon/upgrade/900-ath9k-blackout-workaround
similarity index 100%
rename from ffho/ffho-ath9k-blackout-workaround/files/lib/gluon/upgrade/900-ath9k-blackout-workaround
rename to ffho/ffho-ath9k-blackout-workaround/luasrc/lib/gluon/upgrade/900-ath9k-blackout-workaround
diff --git a/ffho/ffho-ath9k-blackout-workaround/files/usr/sbin/ath9k-blackout-workaround b/ffho/ffho-ath9k-blackout-workaround/luasrc/usr/sbin/ath9k-blackout-workaround
similarity index 100%
rename from ffho/ffho-ath9k-blackout-workaround/files/usr/sbin/ath9k-blackout-workaround
rename to ffho/ffho-ath9k-blackout-workaround/luasrc/usr/sbin/ath9k-blackout-workaround
diff --git a/ffho/ffho-autoupdater-wifi-fallback-legacy/Makefile b/ffho/ffho-autoupdater-wifi-fallback-legacy/Makefile
index ef87c19010ee1d832cff7818a03d4e9f0830b156..b529e6feb6049f31d510084a7175a7de3ba97f0f 100644
--- a/ffho/ffho-autoupdater-wifi-fallback-legacy/Makefile
+++ b/ffho/ffho-autoupdater-wifi-fallback-legacy/Makefile
@@ -6,7 +6,7 @@ PKG_RELEASE:=$(GLUON_VERSION).$(GLUON_SITE_CODE)-$(GLUON_RELEASE).$(GLUON_CONFIG
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
-include $(INCLUDE_DIR)/package.mk
+include $(GLUONDIR)/include/package.mk
 
 define Package/ffho-autoupdater-wifi-fallback-legacy
   SECTION:=ffho
@@ -30,10 +30,11 @@ define Build/Configure
 endef
 
 define Build/Compile
+	$(call GluonSrcDiet,./luasrc,$(PKG_BUILD_DIR)/luadest/)
 endef
 
 define Package/ffho-autoupdater-wifi-fallback-legacy/install
-  $(CP) ./files/* $(1)/
+	$(CP) $(PKG_BUILD_DIR)/luadest/* $(1)/
 endef
 
 $(eval $(call BuildPackage,ffho-autoupdater-wifi-fallback-legacy))
diff --git a/ffho/ffho-autoupdater-wifi-fallback-legacy/files/lib/gluon/upgrade/505-autoupdater-wifi-fallback-legacy b/ffho/ffho-autoupdater-wifi-fallback-legacy/luasrc/lib/gluon/upgrade/505-autoupdater-wifi-fallback-legacy
similarity index 100%
rename from ffho/ffho-autoupdater-wifi-fallback-legacy/files/lib/gluon/upgrade/505-autoupdater-wifi-fallback-legacy
rename to ffho/ffho-autoupdater-wifi-fallback-legacy/luasrc/lib/gluon/upgrade/505-autoupdater-wifi-fallback-legacy
diff --git a/ffho/ffho-autoupdater-wifi-fallback/Makefile b/ffho/ffho-autoupdater-wifi-fallback/Makefile
index 32a8a2ef68cad2bb3d00d5a0f086061fa847603c..23529d2f4e8484a1c19dd1db69c07200d63f7e53 100644
--- a/ffho/ffho-autoupdater-wifi-fallback/Makefile
+++ b/ffho/ffho-autoupdater-wifi-fallback/Makefile
@@ -23,8 +23,14 @@ define Build/Prepare
 	$(CP) ./src/* $(PKG_BUILD_DIR)/
 endef
 
+define Build/Compile
+	$(call Build/Compile/Default)
+	$(call GluonSrcDiet,./luasrc,$(PKG_BUILD_DIR)/luadest/)
+endef
+
 define Package/ffho-autoupdater-wifi-fallback/install
 	$(CP) ./files/* $(1)/
+	$(CP) $(PKG_BUILD_DIR)/luadest/* $(1)/
 
 	$(INSTALL_DIR) $(1)/lib/gluon/respondd
 	$(CP) $(PKG_BUILD_DIR)/respondd.so $(1)/lib/gluon/respondd/autoupdater-wifi-fallback.so
diff --git a/ffho/ffho-autoupdater-wifi-fallback/files/lib/gluon/upgrade/510-autoupdater-wifi-fallback b/ffho/ffho-autoupdater-wifi-fallback/luasrc/lib/gluon/upgrade/510-autoupdater-wifi-fallback
similarity index 100%
rename from ffho/ffho-autoupdater-wifi-fallback/files/lib/gluon/upgrade/510-autoupdater-wifi-fallback
rename to ffho/ffho-autoupdater-wifi-fallback/luasrc/lib/gluon/upgrade/510-autoupdater-wifi-fallback
diff --git a/ffho/ffho-autoupdater-wifi-fallback/files/usr/lib/lua/autoupdater-wifi-fallback/util.lua b/ffho/ffho-autoupdater-wifi-fallback/luasrc/usr/lib/lua/autoupdater-wifi-fallback/util.lua
similarity index 100%
rename from ffho/ffho-autoupdater-wifi-fallback/files/usr/lib/lua/autoupdater-wifi-fallback/util.lua
rename to ffho/ffho-autoupdater-wifi-fallback/luasrc/usr/lib/lua/autoupdater-wifi-fallback/util.lua
diff --git a/ffho/ffho-autoupdater-wifi-fallback/files/usr/sbin/autoupdater-wifi-fallback b/ffho/ffho-autoupdater-wifi-fallback/luasrc/usr/sbin/autoupdater-wifi-fallback
similarity index 100%
rename from ffho/ffho-autoupdater-wifi-fallback/files/usr/sbin/autoupdater-wifi-fallback
rename to ffho/ffho-autoupdater-wifi-fallback/luasrc/usr/sbin/autoupdater-wifi-fallback
diff --git a/ffho/ffho-autoupdater-wifi-fallback/files/usr/sbin/wpa_supplicant b/ffho/ffho-autoupdater-wifi-fallback/luasrc/usr/sbin/wpa_supplicant
similarity index 100%
rename from ffho/ffho-autoupdater-wifi-fallback/files/usr/sbin/wpa_supplicant
rename to ffho/ffho-autoupdater-wifi-fallback/luasrc/usr/sbin/wpa_supplicant
diff --git a/ffho/ffho-autoupdater/Makefile b/ffho/ffho-autoupdater/Makefile
index 512bc09e4934d9f7adc2d6036a286ed3a1cb8e12..7dad7c03de21fbbe9bacf493f6f4008e30291016 100644
--- a/ffho/ffho-autoupdater/Makefile
+++ b/ffho/ffho-autoupdater/Makefile
@@ -24,8 +24,14 @@ define Build/Prepare
 	$(CP) ./src/* $(PKG_BUILD_DIR)/
 endef
 
+define Build/Compile
+	$(call Build/Compile/Default)
+	$(call GluonSrcDiet,./luasrc,$(PKG_BUILD_DIR)/luadest/)
+endef
+
 define Package/ffho-autoupdater/install
 	$(CP) ./files/* $(1)/
+	$(CP) $(PKG_BUILD_DIR)/luadest/* $(1)/
 
 	$(INSTALL_DIR) $(1)/lib/gluon/respondd
 	$(CP) $(PKG_BUILD_DIR)/respondd.so $(1)/lib/gluon/respondd/autoupdater.so
diff --git a/ffho/ffho-autoupdater/files/lib/gluon/upgrade/500-autoupdater b/ffho/ffho-autoupdater/luasrc/lib/gluon/upgrade/500-autoupdater
similarity index 100%
rename from ffho/ffho-autoupdater/files/lib/gluon/upgrade/500-autoupdater
rename to ffho/ffho-autoupdater/luasrc/lib/gluon/upgrade/500-autoupdater
diff --git a/ffho/ffho-config-mode-site-select/Makefile b/ffho/ffho-config-mode-site-select/Makefile
index cdaabea92df1ba97e3c33ed5338f26e9170c149e..9219ec6f9840608ab870141d2084de5544bab97d 100644
--- a/ffho/ffho-config-mode-site-select/Makefile
+++ b/ffho/ffho-config-mode-site-select/Makefile
@@ -6,7 +6,7 @@ PKG_RELEASE:=1
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
-include $(INCLUDE_DIR)/package.mk
+include $(GLUONDIR)/include/package.mk
 
 PKG_CONFIG_DEPENDS += $(GLUON_I18N_CONFIG)
 
@@ -28,10 +28,11 @@ endef
 
 define Build/Compile
 	$(call GluonBuildI18N,ffho-config-mode-site-select,i18n)
+	$(call GluonSrcDiet,./luasrc,$(PKG_BUILD_DIR)/luadest/)
 endef
 
 define Package/ffho-config-mode-site-select/install
-	$(CP) ./files/* $(1)/
+	$(CP) $(PKG_BUILD_DIR)/luadest/* $(1)/
 	$(call GluonInstallI18N,ffho-config-mode-site-select,$(1))
 endef
 
diff --git a/ffho/ffho-config-mode-site-select/files/lib/gluon/config-mode/wizard/0200-site-select.lua b/ffho/ffho-config-mode-site-select/luasrc/lib/gluon/config-mode/wizard/0200-site-select.lua
similarity index 100%
rename from ffho/ffho-config-mode-site-select/files/lib/gluon/config-mode/wizard/0200-site-select.lua
rename to ffho/ffho-config-mode-site-select/luasrc/lib/gluon/config-mode/wizard/0200-site-select.lua
diff --git a/ffho/ffho-debug/Makefile b/ffho/ffho-debug/Makefile
index 53d1fcab681be5e9ceb8cbe20eb66b71e009aec2..47804dc0f3bfd091910298bce470f14645705d82 100644
--- a/ffho/ffho-debug/Makefile
+++ b/ffho/ffho-debug/Makefile
@@ -6,7 +6,7 @@ PKG_RELEASE:=$(GLUON_VERSION).$(GLUON_SITE_CODE)-$(GLUON_RELEASE).$(GLUON_CONFIG
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
-include $(INCLUDE_DIR)/package.mk
+include $(GLUONDIR)/include/package.mk
 
 define Package/ffho-debug
   SECTION:=ffho
@@ -29,11 +29,11 @@ define Build/Configure
 endef
 
 define Build/Compile
+	$(call GluonSrcDiet,./luasrc,$(PKG_BUILD_DIR)/luadest/)
 endef
 
 define Package/ffho-debug/install
-	$(INSTALL_DIR) $(1)/bin/
-	$(INSTALL_BIN) ./files/bin/* $(1)/bin/
+	$(CP) $(PKG_BUILD_DIR)/luadest/* $(1)/
 endef
 
 $(eval $(call BuildPackage,ffho-debug))
diff --git a/ffho/ffho-debug/files/bin/ffho-debug b/ffho/ffho-debug/luasrc/bin/ffho-debug
similarity index 100%
rename from ffho/ffho-debug/files/bin/ffho-debug
rename to ffho/ffho-debug/luasrc/bin/ffho-debug
diff --git a/ffho/ffho-geo-location-altitude-delete/Makefile b/ffho/ffho-geo-location-altitude-delete/Makefile
index 5890580cc50c7c56bfc26329c5bb13dfb0fc55c5..42b5302beb94e06dcb0056d0079b754ca32bba61 100644
--- a/ffho/ffho-geo-location-altitude-delete/Makefile
+++ b/ffho/ffho-geo-location-altitude-delete/Makefile
@@ -6,7 +6,7 @@ PKG_RELEASE:=$(GLUON_VERSION).$(GLUON_SITE_CODE)-$(GLUON_RELEASE).$(GLUON_CONFIG
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
-include $(INCLUDE_DIR)/package.mk
+include $(GLUONDIR)/include/package.mk
 
 define Package/ffho-geo-location-altitude-delete
   SECTION:=ffho
@@ -28,10 +28,11 @@ define Build/Configure
 endef
 
 define Build/Compile
+	$(call GluonSrcDiet,./luasrc,$(PKG_BUILD_DIR)/luadest/)
 endef
 
 define Package/ffho-geo-location-altitude-delete/install
-  $(CP) ./files/* $(1)/
+	$(CP) $(PKG_BUILD_DIR)/luadest/* $(1)/
 endef
 
 $(eval $(call BuildPackage,ffho-geo-location-altitude-delete))
diff --git a/ffho/ffho-geo-location-altitude-delete/files/lib/gluon/upgrade/900-geo-location-altitude-delete b/ffho/ffho-geo-location-altitude-delete/luasrc/lib/gluon/upgrade/900-geo-location-altitude-delete
similarity index 100%
rename from ffho/ffho-geo-location-altitude-delete/files/lib/gluon/upgrade/900-geo-location-altitude-delete
rename to ffho/ffho-geo-location-altitude-delete/luasrc/lib/gluon/upgrade/900-geo-location-altitude-delete
diff --git a/ffho/ffho-luci-autoupdater-wifi-fallback/Makefile b/ffho/ffho-luci-autoupdater-wifi-fallback/Makefile
index b819c002d8a4a3bb82927d16643fde73fbe80318..57dc476140d1545c5c398e9092379c74926986b6 100644
--- a/ffho/ffho-luci-autoupdater-wifi-fallback/Makefile
+++ b/ffho/ffho-luci-autoupdater-wifi-fallback/Makefile
@@ -29,10 +29,11 @@ endef
 
 define Build/Compile
 	$(call GluonBuildI18N,ffho-luci-autoupdater-wifi-fallback,i18n)
+	$(call GluonSrcDiet,./luasrc,$(PKG_BUILD_DIR)/luadest/)
 endef
 
 define Package/ffho-luci-autoupdater-wifi-fallback/install
-	$(CP) ./files/* $(1)/
+	$(CP) $(PKG_BUILD_DIR)/luadest/* $(1)/
 	$(call GluonInstallI18N,ffho-luci-autoupdater-wifi-fallback,$(1))
 endef
 
diff --git a/ffho/ffho-luci-autoupdater-wifi-fallback/files/usr/lib/lua/luci/controller/admin/autoupdater.lua b/ffho/ffho-luci-autoupdater-wifi-fallback/luasrc/usr/lib/lua/luci/controller/admin/autoupdater.lua
similarity index 100%
rename from ffho/ffho-luci-autoupdater-wifi-fallback/files/usr/lib/lua/luci/controller/admin/autoupdater.lua
rename to ffho/ffho-luci-autoupdater-wifi-fallback/luasrc/usr/lib/lua/luci/controller/admin/autoupdater.lua
diff --git a/ffho/ffho-luci-autoupdater-wifi-fallback/files/usr/lib/lua/luci/model/cbi/admin/autoupdater.lua b/ffho/ffho-luci-autoupdater-wifi-fallback/luasrc/usr/lib/lua/luci/model/cbi/admin/autoupdater.lua
similarity index 100%
rename from ffho/ffho-luci-autoupdater-wifi-fallback/files/usr/lib/lua/luci/model/cbi/admin/autoupdater.lua
rename to ffho/ffho-luci-autoupdater-wifi-fallback/luasrc/usr/lib/lua/luci/model/cbi/admin/autoupdater.lua
diff --git a/ffho/ffho-luci-remote-syslog/Makefile b/ffho/ffho-luci-remote-syslog/Makefile
index d73e4444b34a0988df5e134e77eada6b3011cb98..ab86b49071054f2d8c8bb42c02166387102e7beb 100644
--- a/ffho/ffho-luci-remote-syslog/Makefile
+++ b/ffho/ffho-luci-remote-syslog/Makefile
@@ -28,10 +28,11 @@ endef
 
 define Build/Compile
 	$(call GluonBuildI18N,ffho-luci-remote-syslog,i18n)
+	$(call GluonSrcDiet,./luasrc,$(PKG_BUILD_DIR)/luadest/)
 endef
 
 define Package/ffho-luci-remote-syslog/install
-	$(CP) ./files/* $(1)/
+	$(CP) $(PKG_BUILD_DIR)/luadest/* $(1)/
 	$(call GluonInstallI18N,ffho-luci-remote-syslog,$(1))
 endef
 
diff --git a/ffho/ffho-luci-remote-syslog/files/usr/lib/lua/luci/controller/admin/remote-syslog.lua b/ffho/ffho-luci-remote-syslog/luasrc/usr/lib/lua/luci/controller/admin/remote-syslog.lua
similarity index 100%
rename from ffho/ffho-luci-remote-syslog/files/usr/lib/lua/luci/controller/admin/remote-syslog.lua
rename to ffho/ffho-luci-remote-syslog/luasrc/usr/lib/lua/luci/controller/admin/remote-syslog.lua
diff --git a/ffho/ffho-luci-remote-syslog/files/usr/lib/lua/luci/model/cbi/admin/remote-syslog.lua b/ffho/ffho-luci-remote-syslog/luasrc/usr/lib/lua/luci/model/cbi/admin/remote-syslog.lua
similarity index 100%
rename from ffho/ffho-luci-remote-syslog/files/usr/lib/lua/luci/model/cbi/admin/remote-syslog.lua
rename to ffho/ffho-luci-remote-syslog/luasrc/usr/lib/lua/luci/model/cbi/admin/remote-syslog.lua
diff --git a/ffho/ffho-node-tuning/Makefile b/ffho/ffho-node-tuning/Makefile
index d0a5db1ae56a77190bad4a4efe75a5c89aadc6ac..2c58fcecfcd7e34e4918a87d8340df1303f4defc 100644
--- a/ffho/ffho-node-tuning/Makefile
+++ b/ffho/ffho-node-tuning/Makefile
@@ -6,7 +6,7 @@ PKG_RELEASE:=$(GLUON_VERSION).$(GLUON_SITE_CODE)-$(GLUON_RELEASE).$(GLUON_CONFIG
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
-include $(INCLUDE_DIR)/package.mk
+include $(GLUONDIR)/include/package.mk
 
 define Package/ffho-node-tuning
   SECTION:=ffho
@@ -35,11 +35,11 @@ define Build/Configure
 endef
 
 define Build/Compile
+	$(call GluonSrcDiet,./luasrc,$(PKG_BUILD_DIR)/luadest/)
 endef
 
 define Package/ffho-node-tuning/install
-	$(INSTALL_DIR) $(1)/lib/gluon/upgrade/
-	$(INSTALL_BIN) ./files//lib/gluon/upgrade/* $(1)/lib/gluon/upgrade/
+	$(CP) $(PKG_BUILD_DIR)/luadest/* $(1)/
 endef
 
 $(eval $(call BuildPackage,ffho-node-tuning))
diff --git a/ffho/ffho-node-tuning/files/lib/gluon/upgrade/180-increase-arp-caches b/ffho/ffho-node-tuning/luasrc/lib/gluon/upgrade/180-increase-arp-caches
similarity index 100%
rename from ffho/ffho-node-tuning/files/lib/gluon/upgrade/180-increase-arp-caches
rename to ffho/ffho-node-tuning/luasrc/lib/gluon/upgrade/180-increase-arp-caches
diff --git a/ffho/ffho-site-auto-select/Makefile b/ffho/ffho-site-auto-select/Makefile
index 654c3d38e83888090e58453d2e6bafce28ca9c24..8cffbf17aad3b0edd93e66eacc59c7cf16b5bd43 100644
--- a/ffho/ffho-site-auto-select/Makefile
+++ b/ffho/ffho-site-auto-select/Makefile
@@ -8,7 +8,7 @@ PFG_BUILD_DEPENDS := lua-cjson/host
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
-include $(INCLUDE_DIR)/package.mk
+include $(GLUONDIR)/include/package.mk
 
 define Package/ffho-site-auto-select
   SECTION:=ffho
@@ -31,10 +31,11 @@ define Build/Configure
 endef
 
 define Build/Compile
+	$(call GluonSrcDiet,./luasrc,$(PKG_BUILD_DIR)/luadest/)
 endef
 
 define Package/ffho-site-auto-select/install
-	$(CP) ./files/* $(1)/
+	$(CP) $(PKG_BUILD_DIR)/luadest/* $(1)/
 	$(INSTALL_DIR) $(1)/lib/gluon/site-select
 	lua -e 'print(require("cjson").encode(require("cjson").decode(io.open("$(GLUON_SITEDIR)/extra/geo.json"):read("*a"))))' > $(1)/lib/gluon/site-select/geo.json
 endef
diff --git a/ffho/ffho-site-auto-select/files/lib/gluon/upgrade/003-site-auto-select b/ffho/ffho-site-auto-select/luasrc/lib/gluon/upgrade/003-site-auto-select
similarity index 100%
rename from ffho/ffho-site-auto-select/files/lib/gluon/upgrade/003-site-auto-select
rename to ffho/ffho-site-auto-select/luasrc/lib/gluon/upgrade/003-site-auto-select
diff --git a/ffho/ffho-site-auto-select/files/usr/lib/lua/gluon/pointwithinshape.lua b/ffho/ffho-site-auto-select/luasrc/usr/lib/lua/gluon/pointwithinshape.lua
similarity index 100%
rename from ffho/ffho-site-auto-select/files/usr/lib/lua/gluon/pointwithinshape.lua
rename to ffho/ffho-site-auto-select/luasrc/usr/lib/lua/gluon/pointwithinshape.lua
diff --git a/ffho/ffho-site-auto-select/files/usr/sbin/ffho-site-auto-select b/ffho/ffho-site-auto-select/luasrc/usr/sbin/ffho-site-auto-select
similarity index 100%
rename from ffho/ffho-site-auto-select/files/usr/sbin/ffho-site-auto-select
rename to ffho/ffho-site-auto-select/luasrc/usr/sbin/ffho-site-auto-select
diff --git a/ffho/ffho-site-generate/Makefile b/ffho/ffho-site-generate/Makefile
index 847904f3322e66298f1af801b13c579a8fad361c..abeec075fe32b305234b707d71ae9ff3a39dd8c7 100644
--- a/ffho/ffho-site-generate/Makefile
+++ b/ffho/ffho-site-generate/Makefile
@@ -8,7 +8,7 @@ PFG_BUILD_DEPENDS := lua-cjson/host
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
-include $(INCLUDE_DIR)/package.mk
+include $(GLUONDIR)/include/package.mk
 
 define Package/ffho-site-generate
   SECTION:=ffho
@@ -30,10 +30,12 @@ define Build/Configure
 endef
 
 define Build/Compile
+	$(call GluonSrcDiet,./luasrc,$(PKG_BUILD_DIR)/luadest/)
 endef
 
 define Package/ffho-site-generate/install
 	$(CP) ./files/* $(1)/
+	$(CP) $(PKG_BUILD_DIR)/luadest/* $(1)/
 	lua -e 'print(require("cjson").encode(assert(dofile("$(GLUONDIR)/scripts/site_config.lua"))))' > $(1)/lib/gluon/site-select/default.json
 	lua -e 'print(require("cjson").encode(assert(dofile("./scripts/sites.lua"))))' >  $(1)/lib/gluon/site-select/sites.json
 	if [ -e $(GLUON_SITEDIR)/extra/groups.conf  ]; then lua -e 'print(require("cjson").encode(assert(dofile("./scripts/groupes.lua"))))' >  $(1)/lib/gluon/site-select/groups.json; fi
diff --git a/ffho/ffho-site-generate/files/lib/gluon/upgrade/005-set-site-config b/ffho/ffho-site-generate/luasrc/lib/gluon/upgrade/005-set-site-config
similarity index 100%
rename from ffho/ffho-site-generate/files/lib/gluon/upgrade/005-set-site-config
rename to ffho/ffho-site-generate/luasrc/lib/gluon/upgrade/005-set-site-config
diff --git a/ffho/ffho-site-generate/files/usr/lib/lua/gluon/site_generate.lua b/ffho/ffho-site-generate/luasrc/usr/lib/lua/gluon/site_generate.lua
similarity index 100%
rename from ffho/ffho-site-generate/files/usr/lib/lua/gluon/site_generate.lua
rename to ffho/ffho-site-generate/luasrc/usr/lib/lua/gluon/site_generate.lua
diff --git a/ffho/ffho-status-page/Makefile b/ffho/ffho-status-page/Makefile
index ecdcb25ee4ad8d8d0fae579e8ada704a8324da59..1bea65ff34d0c029a8a60cfd96e52e958ad12a33 100644
--- a/ffho/ffho-status-page/Makefile
+++ b/ffho/ffho-status-page/Makefile
@@ -6,7 +6,7 @@ PKG_RELEASE:=$(GLUON_VERSION).$(GLUON_SITE_CODE)-$(GLUON_RELEASE).$(GLUON_CONFIG
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
 
-include $(INCLUDE_DIR)/package.mk
+include $(GLUONDIR)/include/package.mk
 
 define Package/ffho-status-page
   SECTION:=ffho
@@ -31,10 +31,12 @@ define Build/Configure
 endef
 
 define Build/Compile
+	$(call GluonSrcDiet,./luasrc,$(PKG_BUILD_DIR)/luadest/)
 endef
 
 define Package/ffho-status-page/install
 	$(CP) ./files/* $(1)/
+	$(CP) $(PKG_BUILD_DIR)/luadest/* $(1)/
 endef
 
 $(eval $(call BuildPackage,ffho-status-page))
diff --git a/ffho/ffho-status-page/files/lib/gluon/status-page/www/cgi-bin/status b/ffho/ffho-status-page/luasrc/lib/gluon/status-page/www/cgi-bin/status
similarity index 100%
rename from ffho/ffho-status-page/files/lib/gluon/status-page/www/cgi-bin/status
rename to ffho/ffho-status-page/luasrc/lib/gluon/status-page/www/cgi-bin/status
diff --git a/ffho/ffho-txpower-fix/Makefile b/ffho/ffho-txpower-fix/Makefile
index 84a3db2f1afdb7345b37b83d9a481425bdc5409d..28f45eaad4385e9fe2ee37500af05004ca6b7023 100644
--- a/ffho/ffho-txpower-fix/Makefile
+++ b/ffho/ffho-txpower-fix/Makefile
@@ -33,10 +33,11 @@ define Build/Configure
 endef
 
 define Build/Compile
+	$(call GluonSrcDiet,./luasrc,$(PKG_BUILD_DIR)/luadest/)
 endef
 
 define Package/ffho-txpower-fix/install
-	$(CP) ./files/* $(1)/
+	$(CP) $(PKG_BUILD_DIR)/luadest/* $(1)/
 endef
 
 $(eval $(call BuildPackage,ffho-txpower-fix))
diff --git a/ffho/ffho-txpower-fix/files/lib/gluon/upgrade/210-ffho-txpower-fix b/ffho/ffho-txpower-fix/luasrc/lib/gluon/upgrade/210-ffho-txpower-fix
similarity index 100%
rename from ffho/ffho-txpower-fix/files/lib/gluon/upgrade/210-ffho-txpower-fix
rename to ffho/ffho-txpower-fix/luasrc/lib/gluon/upgrade/210-ffho-txpower-fix