diff --git a/ffho/ffho-openwrt-migration-tools/Makefile b/ffho/ffho-openwrt-migration-tools/Makefile
index a68733b38df1d886ddb0d6e4d113c27603a5809e..080f0eecc350bc87d0fb1707f1199a603859e88e 100644
--- a/ffho/ffho-openwrt-migration-tools/Makefile
+++ b/ffho/ffho-openwrt-migration-tools/Makefile
@@ -40,6 +40,7 @@ endef
 define Package/ffho-openwrt-migration-tools/install
 	$(INSTALL_DIR) $(1)/etc/uci-defaults/
 	$(INSTALL_BIN) ./files/etc/uci-defaults/40-wireless-config-hwmode-fix $(1)/etc/uci-defaults/
+	$(INSTALL_BIN) ./files/etc/uci-defaults/90-tl-841v10-autoupdater-to-stable $(1)/etc/uci-defaults/
 endef
 
 $(eval $(call BuildPackage,ffho-openwrt-migration-tools))
diff --git a/ffho/ffho-openwrt-migration-tools/files/etc/uci-defaults/90-tl-841v10-autoupdater-to-stable b/ffho/ffho-openwrt-migration-tools/files/etc/uci-defaults/90-tl-841v10-autoupdater-to-stable
new file mode 100644
index 0000000000000000000000000000000000000000..5ce89e2da493d2c9fdbb4bc48fefff1dec2e4bd4
--- /dev/null
+++ b/ffho/ffho-openwrt-migration-tools/files/etc/uci-defaults/90-tl-841v10-autoupdater-to-stable
@@ -0,0 +1,5 @@
+#!/bin/sh
+[ "$(cat /tmp/sysinfo/board_name)" == "tl-wr841n-v10" ] && \
+	uci set autoupdater.settings.branch="stable" && \
+	uci set autoupdater.settings.enabled=1
+exit 0