From 5ecbfdcb5f815d783fdbc8646e76b2316c181d33 Mon Sep 17 00:00:00 2001
From: Michael Schwarz <post@michael-schwarz.name>
Date: Tue, 22 Dec 2015 10:02:08 +0100
Subject: [PATCH] Set TP-Link 841v10 router models to autoupdater branch stable

  As TP-Link 841v10 are not supported by gluon 2015.1.x, they need to
  be feed with the experimental firmware. Since the experimental firmware
  could break a router, we want these aliens to update only from stable
  versions.
---
 ffho/ffho-openwrt-migration-tools/Makefile                   | 1 +
 .../etc/uci-defaults/90-tl-841v10-autoupdater-to-stable      | 5 +++++
 2 files changed, 6 insertions(+)
 create mode 100644 ffho/ffho-openwrt-migration-tools/files/etc/uci-defaults/90-tl-841v10-autoupdater-to-stable

diff --git a/ffho/ffho-openwrt-migration-tools/Makefile b/ffho/ffho-openwrt-migration-tools/Makefile
index a68733b..080f0ee 100644
--- a/ffho/ffho-openwrt-migration-tools/Makefile
+++ b/ffho/ffho-openwrt-migration-tools/Makefile
@@ -40,6 +40,7 @@ endef
 define Package/ffho-openwrt-migration-tools/install
 	$(INSTALL_DIR) $(1)/etc/uci-defaults/
 	$(INSTALL_BIN) ./files/etc/uci-defaults/40-wireless-config-hwmode-fix $(1)/etc/uci-defaults/
+	$(INSTALL_BIN) ./files/etc/uci-defaults/90-tl-841v10-autoupdater-to-stable $(1)/etc/uci-defaults/
 endef
 
 $(eval $(call BuildPackage,ffho-openwrt-migration-tools))
diff --git a/ffho/ffho-openwrt-migration-tools/files/etc/uci-defaults/90-tl-841v10-autoupdater-to-stable b/ffho/ffho-openwrt-migration-tools/files/etc/uci-defaults/90-tl-841v10-autoupdater-to-stable
new file mode 100644
index 0000000..5ce89e2
--- /dev/null
+++ b/ffho/ffho-openwrt-migration-tools/files/etc/uci-defaults/90-tl-841v10-autoupdater-to-stable
@@ -0,0 +1,5 @@
+#!/bin/sh
+[ "$(cat /tmp/sysinfo/board_name)" == "tl-wr841n-v10" ] && \
+	uci set autoupdater.settings.branch="stable" && \
+	uci set autoupdater.settings.enabled=1
+exit 0
-- 
GitLab